BigBrother Status

Some systems are under maintenance.

Last updated 49 minutes ago

Performance issue BB datacenter

57 minutes ago 2026-09-25 10:57 UTC
Identified
Affected Components: Watch-it Cloud

Identified

57 minutes ago 2026-09-25 10:57 UTC

Found someone tinkering with our hardware

Reported

57 minutes ago 2026-09-25 10:57 UTC

Issues found in the BB datacenter

Affected components